404 When using local Orthanc on windows

Describe Your Question

Hello! I try to use the orthanc server by yarn run dev:orthanc but failed with 404 when fetching data from my local server:

The url /dicom-web/studies is incorrect, which should be /studies. I guess it is due to the incorrect settings about the proxy and qidoRoot/wadoRoot/wadoUriRoot but I don’t know how to do properly.

  • Orthanc version: Orthanc for win64-24.4.0@latest
  • OHIF version: 3.8.0@latest

Other efforts

I also tried local_orthanc.js as my configuration file without using proxy, and modified:

wadoUriRoot: 'http://localhost:8042',
qidoRoot: 'http://localhost:8042',
wadoRoot: 'http://localhost:8042',

My server reacts but got CORS problems. It seems I must use proxy.

What steps can we follow to reproduce the bug?

  1. Run your own orthanc server on localhost:8042
  2. Run yarn run dev:orthanc

Here’s my configurations.

//package.json
"dev:orthanc": "cross-env NODE_ENV=development PROXY_TARGET=/dicom-web PROXY_DOMAIN=http://localhost:8042 APP_CONFIG=config/docker_nginx-orthanc.js webpack serve --config .webpack/webpack.pwa.js"

//docker_nginx-orghanc.js
window.config = {
  routerBasename: '/',
  showStudyList: true,
  extensions: [],
  modes: [],
  // below flag is for performance reasons, but it might not work for all servers
  showWarningMessageForCrossOrigin: true,
  showCPUFallbackMessage: true,
  showLoadingIndicator: true,
  strictZSpacingForVolumeViewport: true,
  defaultDataSourceName: 'dicomweb',
  dataSources: [
    {
      namespace: '@ohif/extension-default.dataSourcesModule.dicomweb',
      sourceName: 'dicomweb',
      configuration: {
        friendlyName: 'Orthanc Server',
        name: 'Orthanc',
        wadoUriRoot: '/wado',
        qidoRoot: '/dicom-web',
        wadoRoot: '/dicom-web',
        qidoSupportsIncludeField: false,
        imageRendering: 'wadors',
        thumbnailRendering: 'wadors',
        omitQuotationForMultipartRequest: true,
      },
    },
    {
      namespace: '@ohif/extension-default.dataSourcesModule.dicomjson',
      sourceName: 'dicomjson',
      configuration: {
        friendlyName: 'dicom json',
        name: 'json',
      },
    },
    {
      namespace: '@ohif/extension-default.dataSourcesModule.dicomlocal',
      sourceName: 'dicomlocal',
      configuration: {
        friendlyName: 'dicom local',
      },
    },
  ],
};

I will appreciate if there’s useful suggestions.