How to connect OHIF with DCM4CHEE arc light secured?

I am trying to connect dcm4chee arc light secured with OHIF version 3.6.0. I want OHIF to use keycloak login credentials and connect to the archive.
I have set up dcm4chee archive using the docker (as described here) and created ohif client in keycloak. I modified the ohif default.js to connect to dcm4chee. Now when I load ohif, it shows black screen:

webpack.pwa.js is set as:
‘Cross-Origin-Opener-Policy’: ‘same-origin’,
‘Cross-Origin-Embedder-Policy’: ‘require-corp’,

Steps to reproduce the bug?

  1. Copy docker-compose file (link above)
  2. Run docker compose up
  3. Login to keycloak and create new client ohif-viewer with following settings:
    Root url: dockerhost
    Redirect uri: dockerhost/*
    web-origins: dockerhost
    with client authentication turned on.

It is my default.js

 wadoUriRoot: 'http://dockerhost/dcm4chee-arc/aets/DCM4CHEE/wado',
        qidoRoot: 'http://dockerhost/dcm4chee-arc/aets/DCM4CHEE/rs',
        wadoRoot: 'http://dockerhost/dcm4chee-arc/aets/DCM4CHEE/rs',
        qidoSupportsIncludeField: false,
        supportsReject: false,
        imageRendering: 'wadors',
        thumbnailRendering: 'wadors',
        enableStudyLazyLoad: true,
        supportsFuzzyMatching: false,
        supportsWildcard: true,
        staticWado: true,
        singlepart: 'bulkdata,video',
  
        requestOptions: {
		          "logRequests": true,
		          "logResponses": false,
		          "logTiming": true
		        }
        bulkDataURI: {
          enabled: true,
          relativeResolution: 'studies',
        },
        omitQuotationForMultipartRequest: true,
        defaultServiceType: "dicomWeb",
	public: {
		  "custom": {
		  	  "keycloak": {
			    "realmName": "dcm4che",
			    "authServerUrl": "http://dockerhost/auth",
		  	  }
		  	}
		  },	
         proxy: {
		    "enabled": false
		  },
        keycloak: {
		    "authRedirectUri": "/studylist",
		    "sslRequired": "none",
		    "clientId": "ohif-viewer",
		    "clientSecret": "********************",
		    "loginStyle": "popup",
		    "realmPublicKey": "************************",	
		  }
      },
  1. Run OHIF using yarn run dev.

Hello! Did you manage to resolve the problem? I have a very similar problem.
However, I don’t use dcm4chee secured, could this be the problem?
In my post are my settings

You can put it behind nginx proxy and ssl secure it